INTELLIscribe "time out" when sending jobs

I have configured INTELLIscribe to send to my network printer. After a few minutes, the job fails due to a "timeout" problem. On certain printers, the job may even print, but  INTELLIscribe e shows a status of "Failed" in the "Print Job Information" window. When I ping the printer, it replies quickly. In the print job "Properties" dialog, you may see a message stating a "timeout" or "List index out of bounds" message.

Some network print servers may not send an acknowledgement (ACK) back to INTELLIscribe after the last part of the print job is received. INTELLIscribe follows the LPR/LPD specifications exactly which state that the LPD should reply with an ACK after the control file and the data file(s). If  INTELLIscribe e does not get an ACK after the last part, the datafile by default, it will not close the connection, nor does the network printer close the connection. With the connection still open, the printer does not think the file has been completely received, and eventually the connection will timeout and the printer does not print the job.

The fix to this problem is rather simple. In step 4 of the "Add or Update Virtual Printer Port" wizard, set the following parameters:

  • Reverse Order: No
  • Control File ACK: Yes
  • Data File ACK: No

All other parameters should be left at the defaults. This should allow INTELLIscribe to close the connection, and the printer to think it has accepted the job. Your print jobs should be fine now.

Note: This problem has been reported in some, but not all, Xerox printers and with an Epilog Legend Engraver.